Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2024 - 00:00 EDT
Scheduled
System maintenance is scheduled for Wednesday, May 15, at 12 a.m. EDT. The system will be unavailable for up to one hour. Please plan accordingly. We apologize for any inconvenience.
Posted May 13, 2024 - 16:52 EDT
This scheduled maintenance affected: Web Application, API, and BridalLive Pay.