AWS Outage Affecting Third-Party Integrations

Incident Report for BridalLive

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:28 EDT

Monitoring

AWS is currently reporting widespread service disruptions that may impact some third-party integrations used by BridalLive, including Twilio, Mailchimp, and file-loading services. BridalLive itself remains online and functional, but users may experience temporary slowness or degraded performance when accessing related features. We are monitoring the situation closely and will update this page as more information becomes available.
Posted Oct 20, 2025 - 13:39 EDT
This incident affected: BridalLive.com, Web Application, and API.